[Top] [All Lists]

RE: [nv-l] How to Deal BadOID's

To: jshanks@us.ibm.com
Subject: RE: [nv-l] How to Deal BadOID's
From: usman.taokeer@s-iii.com
Date: Wed, 15 Jun 2005 16:50:58 +0500
Cc: nv-l@lists.us.ibm.com
Delivery-date: Wed, 15 Jun 2005 12:49:20 +0100
Envelope-to: nv-l-archive@lists.skills-1st.co.uk
In-reply-to: <OF7635FA2D.4166DDC9-ON85257018.0042D057-85257018.0044841D@us.ibm.com>
Reply-to: nv-l@lists.us.ibm.com
Sender: owner-nv-l@lists.us.ibm.com


Sorry for bothering you again James, i am a novice to Tivoli so please bear with me, i followed the same steps i did for Cisco Router to get it removed from the BadOid Smartsets for our Enterasys Switch, but it didn't work. First can you please confirm that : -

.iso.org.dod.internet.private.enterprises.5624.2.1.59 Translates to .  this?

I even modified the snmp_field and ovw_field files and made appropriate entries based upon the above. But when i deleted the device and tried to get it "rediscovered" NetView didn't even discovers it anymore, prior to that it used to discover it but puts it in the BadOiD smartset? What to look for next?


Usman Taokeer

James Shanks <jshanks@us.ibm.com>
Sent by: owner-nv-l@lists.us.ibm.com

06-06-05 05:27 PM
Please respond to

RE: [nv-l] How to Deal BadOID's

Well, now I am confused.

First, did adding those entries to oid_to_type, and oid_to_sym, and
deleting the objects, resolve the problem with the object showing up in the
BadOID smartset or not?  I doubt it because they are incorrect.
resolves to
which is what your two entries in the oid files need to be about.  That's
what is being returned as the sysOID.

Second, not being able to run snmpget means there is some kind of problem
in your installation.  The executable is in \usr\ov\bin, so there should be
no question of finding it.   If you ran it, and it didn't work,because you
got a time-out message, then that would usually indicate that you have an
incorrect community name for the device you are trying to communicate with
in  NetView's SNMP data base.   You can verify that by re-running the
command, this time with the -c flag and what you take to be the correct
community name.  If that works but plain old snmpget doesn't, then your
defaults are incorrect and you need to run snmpconf.exe (Start --> Programs
--> Tivoli NetView --> Tasks --> SNMP Options  or Options --> SNMP from the
NetView GUI).

James Shanks
Level 3 Support  for Tivoli NetView for UNIX and Windows
Tivoli Software / IBM Software Group

            Sent by:                                                   To
            owner-nv-l@lists.         nv-l@lists.us.ibm.com              
            us.ibm.com                                                 cc
            06/06/2005 03:32          RE: [nv-l] How to Deal BadOID's    
            Please respond to                                            


Thanks for the help, i was for some reason not able to run the snmpget
command. But i used the SNMP Browser to get the required values:
the output of the SNMP Browser for system.sysObjectID was: -

Node Name or Address:

Community Name: enterasys

MIB Object ID: .iso.org.dod.internet.mgmt.mib-2.system

MIB Instance:

Set Value:

MIB Value:
       0 :

Message: Using community "enterasys" for node

I've translated it to the following and have made the entries in the
"oid_to_type" and "oid_to_sym" files:- Systems:Cisco 3745:G        #oid_to_type #oid_to_sym



James Shanks <jshanks@us.ibm.com>                                        
Sent by: owner-nv-l@lists.us.ibm.com                                      
03-06-05 08:58 PM                                                      cc
           Please respond to                      RE: [nv-l] How to Deal  
         nv-l@lists.us.ibm.com                    BadOID's                

Show us the entry you put in oid_to_type,  and  the one in oid_to_sym,  and
the results of doing this
     snmpget system.sysObjectID.0 <target_box>
from a command window.

If the OIDs match, then it should be removed from the  BadOID smartset
after you

1. delete the objects from all submaps  (select it and do Edit --> All
submaps --> Cut)
2.  ovstop netmon
3. ovtopofix  (in a command window)
4. ovstart netmon

Worked for me on NetView for Windows with a United Linux OID this morning

James Shanks
Level 3 Support  for Tivoli NetView for UNIX and Windows
Tivoli Software / IBM Software Group

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web