[Top] [All Lists]

Re: New map sort of created - cannot delete it.

To: nv-l@lists.tivoli.com
Subject: Re: New map sort of created - cannot delete it.
From: Leslie Clark <lclark@US.IBM.COM>
Date: Fri, 17 Sep 1999 01:46:58 -0400
I was not using security when I made mine either. It happened when I
tested the global map permissions (the -G of ovwperms). I did not expect
it to leave that bit of trash around. It looks to me like the way to prevent it
is to not try it (save map as.. or create.. from a user without r/w permissions
on the map database). In fact, maybe you would like to be the one to call
support and see if they will accept an apar on it. With 5.1.2 shipping, maybe
they are looking for new bugs to fix? I would wait until hurricane Floyd moves
out to sea, though. Raleigh was shut down today as a precaution.


Leslie A. Clark
IBM Global Services - Systems Mgmt & Networking


Thanks.  mapadmin -f <name> removed them.

Any suggestions to prevent them from being recreated?  I saw your last post
on map permissions that references the srf.  We're not using NetView


-----Original Message-----
From: Leslie Clark <lclark@US.IBM.COM>
Date: Monday, September 13, 1999 11:22 PM
Subject: Re: New map sort of created - cannot delete it.

>Sounds like a job for 'mapadmin'. See the man page. I made one like that
>today too and will check it out tomorrow.
>Leslie A. Clark
>IBM Global Services - Systems Mgmt & Networking
>I was playing with setting of map permissions trying to restrict non-root
>users from creating and deleting maps.  I seem to have created a "map stub
>entry" (for lack of a better term) and cannot get rid of it.
>I set ovwperms -G -m 644 and then tried to test it.  I started the NetView
>Gui (nv6000) as a non-root user, then selected the menu File -  new map and
>delete map were not greyed out.  So I selected New Map, gave it a name, and
>clicked ok.  I received a popup "Unable to create a new map.  Permission
>denied".  So far so good.  But then I selected File-->Open Map and it
>the default map and the "new" map (that had been "denied").  The new map
>shows permissions "unknown" and comments "Non-local map (node name...)"
>where node name is our one and only Netview server (no clients).  I
>the new map, yet the delete option remained greyed out.  Tried the File-->
>Delete Map, and same results.  I closed the GUI, logged in as root and
>restarted the GUI (nv6000).  Selected File--> Delete Map and same results:
>delete button was greyed and non-selectable.  From the CLI, entered ovwls
>and the default and new mapname were both listed.  Looked in
>/usr/OV/databases/openview/mapdb and it only showed the default map.  Did a
>find on all file systems, and cannot find a file with the new mapname. I
>can't tell the contents of the new map because I cannot open it.
>Where is this new map/mapname buried, how can it be deleted, and how can I
>prevent admins from creating more of them?
>What is the impact?
>This is recreatable (I now have two extra maps...).
>Envmt:  AIX 4.3.2, NV 5.1.1
>Thanks in advance for any assistance / insights.
>Karin Binder

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web