[Top] [All Lists]

RE: [nv-l] The nvpagerd process not starting

To: "'nv-l@lists.us.ibm.com'" <nv-l@lists.us.ibm.com>
Subject: RE: [nv-l] The nvpagerd process not starting
From: "Montgomery, Ricky G. NCR-DOIM" <ricky.montgomery@belvoir.army.mil>
Date: Thu, 2 Jun 2005 13:22:22 -0400
Delivery-date: Thu, 02 Jun 2005 18:22:57 +0100
Envelope-to: nv-l-archive@lists.skills-1st.co.uk
Reply-to: nv-l@lists.us.ibm.com
Sender: owner-nv-l@lists.us.ibm.com
Thanks Joe.  I increased the value of semmni to 60 with the following
command in the /etc/system file:

        set semsys:seminfo_semmni=60

The default was 10... That seems to have solved the problem.

-----Original Message-----
From: Joe Fernandez [mailto:jfernand@kardinia.com] 
Sent: Thursday, June 02, 2005 5:00 AM
To: nv-l@lists.us.ibm.com
Subject: Re: [nv-l] The nvpagerd process not starting

28, I believe, says the number of semaphores or semaphore sets has been

You increased the number of semaphores but not the number of  semaphore set
identifiers. The parameter is semmni.

At 04:25 PM 01-06-05 -0400, you wrote:
>I'm not a Solaris admin so I don't know whether what you have done is 
>correct or not.
>The code is pretty straightforward even if the system commands are not 
>If you look at the  nvpagerd.alog you printed it says
>IpcKey: 0x6e064538
>which is the important thing here.  Because to create the queue we did 
>a shmget using that key, and it must have worked because you see the
>06/01/05 13:38:57 Allocated shared PAGE_Q, size = 500 But when we tried 
>to get the semaphore for it with semget using that same key, we got a 
>-1 return code.
>           head->Semaphore = semget(IpcKey, 1, IPC_CREAT | S_IRUSR | 
>The 28 is an errno set by the system call, but I haven't the faintest 
>idea what that means on Solaris.
>Sorry, but that's about all I can tell you.
>James Shanks
>Level 3 Support  for Tivoli NetView for UNIX and Windows Tivoli 
>Software / IBM Software Group
>              "Montgomery,
>              Ricky G.
>              NCR-DOIM"                                                  To
>              <ricky.montgomery         "'nv-l@lists.tivoli.com'"
>              @belvoir.army.mil         <nv-l@lists.tivoli.com>
>              >                                                          cc
>              Sent by:
>              owner-nv-l@lists.                                     Subject
>              us.ibm.com                [nv-l] The nvpagerd process not
>                                        starting
>              06/01/2005 02:43
>              PM
>              Please respond to
>                    nv-l
>I have installed a fresh instance of Netview 7.1.4 using the Framework 
>install method (TMF 4.1.1) and patched with Netview FP03. Upon startup 
>the nvpagerd process fails. When I look in the nvpagerd.alog file the 
>error seems to point to the inability to get semaphores.  I have 
>modified the /etc/system file on our Solaris 8 server to increase the 
>number of semaphores and rebooted.  That did not work. Any help is 
>The nvpagerd.alog Content:
>(C) Copyright IBM Corporation 1990, 1993, All Rights Reserved.
>06/01/05 13:38:57 - START /usr/OV/bin/nvpagerd as PID 8142
>IpcKey: 0x6e064538
>06/01/05 13:38:57 Allocated shared PAGE_Q, size = 500
>06/01/05 13:38:57 Error: Couldn't get PAGE_Q semaphore
>Error: Couldn't create queue, page_q_err: 28
>06/01/05 13:38:57 - STOP /usr/OV/bin/nvpagerd as PID 8142
>The nvpagerd.errlog:
>06/01/05 13:38:57 Error: Couldn't get PAGE_Q semaphore
>Error(/usr/OV/bin/nvpagerd): Couldn't create queue, page_q_err: 28
>The /etc/system file additions for Netview:
>set semsys:seminfo_semmns=256
>set semsys:seminfo_semmsl=128
>set msgsys:msginfo_msgmax = 0x8000
>set msgsys:msginfo_msgmnb = 0x8000
>set msgsys:msginfo_msgseg = 0x1000
>Ricky Montgomery
>Tech Control, NCR-DOIM

Joe Fernandez
Kardinia Software

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web