[Top] [All Lists]


To: "'Tivoli NetView Discussions'" <nv-l@lists.ca.ibm.com>
From: "Gino D'Ambrosio" <gino.dambrosio@senetas.com>
Date: Tue, 4 Sep 2007 21:47:50 +1000
Delivery-date: Tue, 04 Sep 2007 12:52:15 +0100
Envelope-to: nv-l-archive@lists.skills-1st.co.uk
In-reply-to: <CE67133097F05C4B938A5482E32525E203759FF6@segotn647.vcn.ds.volvo.net>
List-help: <mailto:nv-l-request@lists.ca.ibm.com?subject=help>
List-id: Tivoli NetView Discussions <nv-l.lists.ca.ibm.com>
List-post: <mailto:nv-l@lists.ca.ibm.com>
List-subscribe: <http://lists.ca.ibm.com/mailman/listinfo/nv-l>, <mailto:nv-l-request@lists.ca.ibm.com?subject=subscribe>
List-unsubscribe: <http://lists.ca.ibm.com/mailman/listinfo/nv-l>, <mailto:nv-l-request@lists.ca.ibm.com?subject=unsubscribe>
References: <CE67133097F05C4B938A5482E32525E203759FF6@segotn647.vcn.ds.volvo.net>
Reply-to: Tivoli NetView Discussions <nv-l@lists.ca.ibm.com>
Sender: nv-l-bounces@lists.ca.ibm.com
Thread-index: AcfuQMpvB4SvTBduQWuuhvJrsZqH4gApvK8g
I ran into this very same issue only a few weeks ago. Here's three steps I took to resolve it ...
Step 1.
     Concatenate the two mib files together (VMWARE-ROOT-MIB.mib + VMWARE-TRAPS-MIB.mib) into one file in order to side step the linkage error.
Step 2:
     I still had warnings issued when using mib2trap so instead used mibloader.sh to generate the addtrap script ...
     /usr/OV/bin/mibloader.sh --mib2Trap VMWARE-TRAPS-MIB.mib --mib2TrapOut VMWARE-TRAPS-MIB.sh
Step 3:
     I then found the resulting script containing all the addtrap statements errored because it was missing the -o option in each of the addtrap statements.
     I manually added the VMWare enterprise OID string in after the -o flags. I think it was this one Then the script worked.
Gino D'Ambrosio

From: nv-l-bounces@lists.ca.ibm.com [mailto:nv-l-bounces@lists.ca.ibm.com] On Behalf Of Mongin Julien
Sent: Tuesday, 4 September 2007 1:52
To: nv-l@lists.ca.ibm.com

Hi all,

I have some troubles to add the VMWARE-TRAPS-MIB in Netview.

I have successfully loaded in Netview:



When I tried to execute mib2trap am Error message :

./mib2trap /usr/OV/snmp_mibs/VMWARE-TRAPS-MIB.mib /tmp/VMWARE-TRAPS-MIB.trap

Warning: The mib description doesn't seem to be consistent.

 Some nodes couldn't be linked under the "iso" tree.

 These nodes are left:

Left-over node vpxdObjValue ::= { vmwTraps 306 } (1)

Left-over node vpxdNewStatus ::= { vmwTraps 305 } (1)

Left-over node vpxdOldStatus ::= { vmwTraps 304 } (1)

Left-over node vpxdVMName ::= { vmwTraps 303 } (1)

Left-over node vpxdHostName ::= { vmwTraps 302 } (1)

Left-over node vpxdTrapType ::= { vmwTraps 301 } (1)

Left-over node vmConfigFile ::= { vmwTraps 102 } (1)

Left-over node vmID ::= { vmwTraps 101 } (134)

Enterprise object id not found for trap vmPoweredOn, (6,1).Enterprise object id not found for trap vmPoweredOff, (6,2).Enterprise object id not found for trap vmHBLost, (6,3).Enterprise object id not found for trap vmHBDetected, (6,4).Enterprise object id not found for trap vmSuspended, (6,5).Enterprise object id not found for trap vpxdTrap, (6,201).

Do you have some Ideas to help ?



NV-L mailing list
http://lists.ca.ibm.com/mailman/listinfo/nv-l (Browser access limited to 
internal IBM'ers only)
<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web