[Top] [All Lists]

Re: Error during reading background file

To: nv-l@lists.tivoli.com
Subject: Re: Error during reading background file
From: Michael Seibold PTS/M-SW <mseibold@STR.DAIMLER-BENZ.COM>
Date: Fri, 31 Jul 1998 09:03:05 +0200
Organization: str.daimler-benz.com
Reply-to: Discussion of IBM NetView and POLYCENTER Manager on NetView et alia <NV-L@UCSBVM.UCSB.EDU>
Sender: Discussion of IBM NetView and POLYCENTER Manager on NetView et alia <NV-L@UCSBVM.UCSB.EDU>
Hi Philipp,

below are some answers to your question which came during the last few
weeks. How about saving these mails on your machine or looking in the


Michael Seibold
debis Systemhaus GmbH


You can have a corrupt file in /usr/OV/bitmap/C (Zero length for
You must also verify that you have the ".m" and the ".p" files for the
If it doesn't resolve the problem, you must try to remove (move in
directory) the files one at a time ... (not really cool I know ...)

Hope this will help !

  Dominique JEANNEROD. Responsable technique
|        APOGEE Communications, Agence Sud-Est                 |
|        113 boulevard Stalingrad, 69100 VILLEURBANNE          |
|        Phone : 0478173838 -- Fax : 0478173839                |
|        jeannerod@apogee-com.fr


I had the same problem on one of my netviews , i checked the background
files and found out that i had two files with different sizes from my
other netview-system.
After i had copied the good files over the corrupt ones , the message
disappeared .
Probably something went wrong when you copied this files from CD in the
installation process.
Try to restore an older version of your background-files or delete the
corrupt files , if you don't need them and if you can find out which one
is causing the problem .


I experienced this problem after the installation of Optivity 8.1. The
cause was a missing file in the /usr/OV/bitmaps/C directory.

Execute the command "nv6000 -fields" and watch for an "Error" command.
If you encounter one, search the bad or missing file that's causing the
problem. It is rather easy to make yourself a new, corrrect file with
just a bitmap editor.

Davy Goris
Orda-B Belgium


I encountered this problem today after installing Optivity 8.1. The
problem was a missing bitmap file. So I created a correct bitmap file,
which I attatch to this email (it's only 178 bytes gzipped).

Do the following commands (as root) to correct the problem without
deleting any bitmap files :

<put the file baynet_baystack-150.38.m.gz in /tmp. If FTP'ing, use
binary mode>
# cd /tmp
# gzip -d baynet_baystack-150.38.m.gz
# chmod u+w /usr/OV/bitmaps/C
# cp baynet_baystack-150.38.m /usr/OV/bitmaps/C
# chmod a-w /usr/OV/bitmaps/C/baynet_baystack-150.38.m
<exit any netview clients>
# /usr/OV/bin/ovw -config
# chmod u-w /usr/OV/bitmaps/C

This worked fine with me. The only thing I did to resolv the "Error when
reading file background" message, was this patch, so I'm pretty sure
that this missing file caused the problem.

Since I know that the people from Bay Networks also follow this mailing
list, I am not opening this case with them. I trust that you won't sue
me for distributing your source code :-) Although, it's actually my
source code. But I won't sue you for distributing it :-)

I hope this solves the problem for everone,

Davy Goris
System & Network Engineer
Orda-B Belgium

>From:  Stephen A Houle[SMTP:stephen_a_houle@SMB.COM]
>Sent:  dinsdag 26 mei 1998 23:23
>Subject:       Re[2]: Error when Neview startup
>     I didn't have any zero length files either.  I forget who suggested it
>     here, but I deleted all the files in /usr/OV/bitmaps/C without file
>     extentions on them (delete "c3000", not "c3000.20.m"), and ran
>     "/usr/OV/bin/ovw -config".
>     Solved my problem.
>     Steve Houle



Anthony Philipp wrote:
> I am receiving a pop-up error message when starting Netview that reads
> "Error during reading background file".  I started getting this message
> after I reloaded CiscoWorks 4.0 onto Netview 5.0 - AIX 4.2.1.  I only have
> one map and I have never set any background bitmaps.  I think I rememebr a
> solution to this problem being posted a few months ago.  Does anyone recall
> how to fix this problem?  Thanks.

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web