[Top] [All Lists]

Re: addtrap problem

To: nv-l@lists.tivoli.com
Subject: Re: addtrap problem
From: Mythili Kannan <mythili@anytech-inc.com>
Date: Sun, 08 Oct 2000 22:45:48 -0400
I had the same problem that Ray had when adding trap definitions for Cisco
devices as well.  I did not get any error when I ran mib2trap command.
Either mib2trap has a bug or the falgs for addtrap command were modified
and mib2trap is not compatible with the lates addtrap command.

I changed the order of addtrap in the output file generated by mib2trap
utility in the follwing order and I was successful.  The order that worked
for me was:
addtrap -n enterprisename \
         -l label \
         -i enterprise-ID \
         -g generic ID \
         -s specific ID \
         -o source ID \
         -S severity \
         -D Description \
         -e class name \
         -F format specification

Hope this helps.

- Mythili

At 09:27 PM 10/8/00 -0400, James_Shanks@tivoli.com wrote:
>You are getting this message because one of the required elements for an
>to be successful is missing.  From what I can see it is the enterprise id,
>is specified with the "-i" parameter.  My guess is that when you ran mib2trap
>against that file that you got an error message which basically said that
>mib2trap could not determine the enterprise id, and so it was omitted from
>addtrap command which was built.  You will have to determine what that
>enterprise id should be and add it to the addtrap command in order for it to
>work.  It will begin with .  which is the identifier down to
>but after that it will be unique to the 8272.  You will probably have to
look at
>the mibfile which you used with mib2trap and work backwards to the other
>it relied on.  Since mib2trap works on MIB files and not on the database, it
>cannot know what others should be referenced.
>Hope this helps
>James Shanks
>Team Leader, Level 3 Support
> Tivoli NetView for UNIX and NT
>"Ray Westphal" <rwestphal@erac.com> on 10/06/2000 05:37:15 PM
>Please respond to IBM NetView Discussion <nv-l@tkg.com>
>To:   "NV List (E-mail)" <nv-l@tkg.com>
>cc:    (bcc: James Shanks/Tivoli Systems)
>Subject:  [NV-L] addtrap problem
>Hello Everone.
>Here's an excerpt from an script created by mib2trap command against
>trs_402b.trp file. This file is shipped with the 8270
>/usr/OV/bin/addtrap -l ibm8272TsTempThreshold -g 6 -s 1 \
>   -n ibm8272TsSys  \
>   -o A  -c "LOGONLY" -t 0 \
>   -S 1  \
>   -D "This trap is generated when the system temperature
>either exceeds 50 C or when it returns to normal(45 C)
>after exceeding the temperature. The variable
>ibm8272Ts2SysTemperature indicates the temperature
>condition at the time of the event."  \
>   -e ibm8272TsTempThreshold  \
>   -F '$E $G $S $# args: $*'
>The addtrap fails with the following message.
>If arguments contain space, use the double quotation mark.
>I've tried a number of things. Does anyone have a suggestion?
>Ray Westphal
>NV-L List information and Archives: http://www.tkg.com/nv-l
>NV-L List information and Archives: http://www.tkg.com/nv-l
Mythili Kannan
AnyTech Inc
14433 Settlers Landing Way
N.Potomac, MD 20878
Phone/Fax: (301) - 738 - 2419
Cell    : (202) - 607 - 4810
URL     :<http://www.anytech-inc.com>

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web