[Top] [All Lists]

Re: [nv-l] snmpv2 data collection and mib browsing

To: nv-l@lists.us.ibm.com
Subject: Re: [nv-l] snmpv2 data collection and mib browsing
From: James Shanks <jshanks@us.ibm.com>
Date: Mon, 19 Dec 2005 08:49:14 -0500
Delivery-date: Mon, 19 Dec 2005 13:49:49 +0000
Envelope-to: nv-l-archive@lists.skills-1st.co.uk
In-reply-to: <671374730512190156x127fe531sffec90517337a2c3@mail.gmail.com>
Reply-to: nv-l@lists.us.ibm.com
Sender: owner-nv-l@lists.us.ibm.com
I'm sorry but adding things to the Windows GUI is out of my area of
expertise, though for the life of me I cannot see how it could fail to work
if you specify a full path for your command.  My only suggestion is that
you contact Support and open a problem so that someone with expertise in
this area can assist.

James Shanks
Level 3 Support  for Tivoli NetView for UNIX and Windows
Tivoli Software / IBM Software Group

             Oswin Budiman                                                 
             com>                                                       To 
             Sent by:                  nv-l@lists.us.ibm.com               
             owner-nv-l@lists.                                          cc 
                                       Re: [nv-l] snmpv2 data collection   
             12/19/2005 04:56          and mib browsing                    
             Please respond to                                             

Thanks a lot for the reply James, I already contact Maria and waiting
for further info about it.
I guess I have to bear with this problem for quite a while...

By the way, I tried to make a toolbar menu by creating a file in the
registration folder. It works fine if I link it to the application
(.exe) that resides in \usr\ov\bin. But if I try to link the menu to a
batch files or any other application it won't load at all. Do you have
any suggestion on how to run external application with our own menu
toolbar from netview menu? I want to run the web console mib browser
from the native console if it's possible.



On 12/17/05, James Shanks <jshanks@us.ibm.com> wrote:
> Well, what you see is what you get, I am sorry to say.
> In the current release of NetView, SNMPv2 support is not fully
> and there is even less of it in the Windows version than in the UNIX
> version.  The UNIX version has a command line SNMPv2 interface, which is
> not well-documented nor well-understood, but at least it is there for
> people who have to roll-their-own v2c solutions.  I won't dwell on that
> here, however.
> The need for full SNMPv2 and SNMPv3 support is well-understood by NetView
> development, and while it is being worked on, I cannot give you a date
> it; no one can unless you contact your IBM marketing representative and
> sign a nondisclosure agreement.  IBM does not announce such things
> until the product is ready to ship.
> If these devices truly will not respond to SNMPv1 queries in any way,
> you are very much restricted.  netmon discovery uses only SNMPv1 at this
> time, as does snmpcollect, and the native MIB browsers, both browser and
> browserv2.  Yes, even browserv2 sends its SNMP packet in SNMPv1-format,
> just like snmpcollect.  So if the browserv2 doesn't work, neither will
> snmpcollect.  The only way these things will work is if the agent you
> is bilingual and speaks SNMPv1 as well as V2c.   As you have discovered,
> the only full SNMPv2 agent in NetView is the web console MIB browser.
> Your only other option in this regard, that I can see at this time,  is
> obtain the SNMP Research Security Pack, which, when installed, will
> intercept the SNMPv3 packets and translate them into SNMPv1 for NetView.
> am not certain whether it will do this for SNMPv2; you would have to
> contact them for that.  But I saw on the web that your Motorola devices
> be configured to do SNMPv3 as well as SNMPv2c, so that might give you a
> to go in the short run.
> James Shanks
> Level 3 Support  for Tivoli NetView for UNIX and Windows
> Tivoli Software / IBM Software Group
>              Oswin Budiman
>              <armahalma@gmail.
>              com>
>              Sent by:                  nv-l@lists.tivoli.com
>              owner-nv-l@lists.
>              us.ibm.com
>                                        [nv-l] snmpv2 data collection and
>              12/16/2005 04:21          mib browsing
>              AM
>              Please respond to
>                    nv-l
> Hi all, I'm a new user to tivoli netview.
> Recently our company triy to implement netview in one of our customer,
> but the problem is they have some devices that only support snmpv2. So
> after doing hours of investigation throughout this mailing list
> archive, I presume netview does not fully support snmpv2, but it
> support partially by giving abilities to load mibv2 via loadmibv2 or
> web console mib loader, browse it via browserv2 or mibbrowser.jar, and
> collect the data by manually editing snmpcol.conf.
> and I have some desperate questions about that:
> 1. Does somebody know when IBM will release the next version to fully
> support v2? Most of our customer is really concerned about it; they
> don't want to use netview unless it support all device that they
> have...
> 2. How can an only-snmpv2-supported device be recognized as a
> snmpSupported device on discovery process? Coz whenever i look at the
> device, it's only recognized as a common node, so I couldn't do
> anything with it... is there something related to snmpwalk? coz when i
> try to walk the device, it just time-out. But using other software
> (orion eg.) I can walk it successfully.
> 3. I tried to load the device mib via loadmibv2 and web console, and
> it loaded successfully, and I able to browse it. But why I can't
> browse to mib-2 OID in browserv2.exe to get the traffic statistic
> (such as ifInOctets)? I can get the statistic using web console
> browser, but I couldn't do it using browserv2, coz there's no child
> item below mgmt node mib...
> 4. I tried to manually edit snmpcol.conf in attempt to collect the
> data from the device, there are no error message whatsoever and the
> status said that it was "Collecting", but there were no data at all
> when I try to see it. But when I use the mibbrowser.jar, I can walk
> the traffic data perfectly. Is there something wrong with it? Here's a
> few line I made manually:
> MIB . .* radioSlicing units INTEGER R
> C 0xffffffff 30 > 0.000000 <= 0.000000 x% s 58720263
> MIB . .* ifInOctets units COUNTER R ljkttivoli
> C 0xffffffff 30 > 0.000000 <= 0.000000 xA s 58720263
> I also tried the tool builder to collect the data but to no avail at
> all. It said there was nothing to graph from the device.
> 5. Actually I want to ask about trapping with v2, but I guess it's
> hopeless with this data collection problem... I figured it will be
> pretty easy once we able to collect the data.
> FYI, the device we tried to collect is motorola canopy wireless bridge
> and tenor voice devices. Our netview version is 7.1.4 with Fixpack 3
> on windows 2k3 platform using MSSQL 2k database. Any help is highly
> appreciated!
> Thanks.
> btw. sorry about the language, i'm not a native speaker if u ask.
> Regards,
> Oswin

<Prev in Thread] Current Thread [Next in Thread>

Archive operated by Skills 1st Ltd

See also: The NetView Web